Cannot send a Search request

Apr 22, 2015 at 10:38 PM
Hello,

I'm using the "EAS Conversations" part of the tool. In the tool, I select "Search" for the Command field and then I load the search.xml sample. When I run the request, I get the following error:

StatusCode: 142
Meaning: DeviceNotProvisioned

I then change the Command field to "Provision" and then load the "Provsion - first part.xml" sample. I'm able to provsion, but when I change the Command field back to "Search" and load the Search.xml sample, I get the same error as before.

What what is the proper way to test a "Search" request with this tool?

Thanks
sclincoln
Developer
May 5, 2015 at 7:25 AM
Provisioning is a 2-step process. After sending a provision command, you must send the second part of the handshake. The response to that second part will contain the permanent policy key, which you must then send with all subsequent commands in the X-MS-PolicyKey header.
Sep 24 at 10:58 AM
Hello,

I'm trying to send a provisioning request using the existing example without success.

I have this error message : Input string was not in a correct format.

Is there any modification to do in the proposed xml text, please ?

Thanks,
Sofiane